Add _opam and .vscode to .gitignore

For:

- Local opam switches.
- Workspace settings for OCaml Platform VSCode extension.
0 jobs for !1 with gitignore
latest yaml invalid error detached

Found errors in your .gitlab-ci.yml:

  • Project `OCamlPro/gitlab-deployments` not found or access denied!
You can also test your .gitlab-ci.yml in CI Lint